What’s Vulnerable › Vulnerabilities
CVE-2022-3222: Uncontrolled Recursion in gpac/gpac
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-15 · updated 2026-06-17
- Weakness: CWE-674
Description
Uncontrolled Recursion in GitHub repository gpac/gpac prior to 2.1.0-DEV.
Affected products
- GPAC: before 2.1; 2.1-dev — fixed in 2.1
How to fix
Upgrade to a fixed version: GPAC 2.1. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/4e7736d7ec7bf64026daa611da951993bb42fdaf
- https://huntr.dev/bounties/b29c69fa-3eac-41e4-9d4f-d861aba18235
- https://www.debian.org/security/2023/dsa-5411
- https://github.com/gpac/gpac/commit/4e7736d7ec7bf64026daa611da951993bb42fdaf
- https://huntr.dev/bounties/b29c69fa-3eac-41e4-9d4f-d861aba18235
- https://www.debian.org/security/2023/dsa-5411
Get alerted when CVE-2022-3222 or the next vulnerability affects your stack