What’s Vulnerable › Vulnerabilities

CVE-2022-32222

Description

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

Affected products

How to fix

Upgrade to a fixed version: Node.js 18.5.0; Siemens SINEC INS 1.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-32222 or the next vulnerability affects your stack