What’s Vulnerable › Vulnerabilities
CVE-2022-32227
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-23 · updated 2026-06-17
- Weakness: CWE-319
Description
A cleartext transmission of sensitive information exists in Rocket.Chat <v5, <v4.8.2 and <v4.7.5 relating to Oauth tokens by having the permission "view-full-other-user-info", this could cause an oauth token leak in the product.
Affected products
- Rocket.Chat: before 4.7.5; from 4.8.0 before 4.8.2 — fixed in 4.7.5, 4.8.2
How to fix
Upgrade to a fixed version: Rocket.Chat 4.7.5, 4.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-32227 or the next vulnerability affects your stack