What’s Vulnerable › Vulnerabilities
CVE-2022-32278
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-13 · updated 2026-06-17
Description
XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file on an attacker-controlled FTP server.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Xfce Exo: before 4.16.4; from 4.17.0 before 4.17.2 — fixed in 4.16.4, 4.17.2
How to fix
Upgrade to a fixed version: Xfce Exo 4.16.4, 4.17.2. Check the vendor advisory for mitigations.
References
- https://gitlab.xfce.org/xfce/exo/-/commit/c71c04ff5882b2866a0d8506fb460d4ef796de9f
- https://lists.debian.org/debian-lts-announce/2022/06/msg00018.html
- https://www.debian.org/security/2022/dsa-5164
- https://gitlab.xfce.org/xfce/exo/-/commit/c71c04ff5882b2866a0d8506fb460d4ef796de9f
- https://lists.debian.org/debian-lts-announce/2022/06/msg00018.html
- https://www.debian.org/security/2022/dsa-5164
Get alerted when CVE-2022-32278 or the next vulnerability affects your stack