What’s Vulnerable › Vulnerabilities
CVE-2022-32285
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-14 · updated 2026-06-17
- Weakness: CWE-611
Description
A vulnerability has been identified in Mendix SAML Module (Mendix 7 compatible) (All versions < V1.16.6), Mendix SAML Module (Mendix 8 compatible) (All versions < V2.2.2), Mendix SAML Module (Mendix 9 compatible) (All versions < V3.2.3). The affected module is vulnerable to XML External Entity (XXE) attacks due to insufficient input sanitation. This may allow an attacker to disclose confidential data under certain circumstances.
Affected products
- Siemens Mendix SAML Module: before 1.16.6; from 2.0.0 before 2.2.2; from 3.0.0 before 3.2.3 — fixed in 1.16.6, 2.2.2, 3.2.3
How to fix
Upgrade to a fixed version: Siemens Mendix SAML Module 1.16.6, 2.2.2, 3.2.3. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-740594.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-740594.pdf
Get alerted when CVE-2022-32285 or the next vulnerability affects your stack