What’s Vulnerable › Vulnerabilities
CVE-2022-3231: Cross-site Scripting (XSS) - Stored in librenms/librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.9.0.
Affected products
- librenms: before 22.9.0 — fixed in 22.9.0
How to fix
Upgrade to a fixed version: librenms 22.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/08050020861230ff96a6507b309cc172a9e70af8
- https://huntr.dev/bounties/bcb6ee68-1452-4fdb-932a-f1031d10984f
- https://github.com/librenms/librenms/commit/08050020861230ff96a6507b309cc172a9e70af8
- https://huntr.dev/bounties/bcb6ee68-1452-4fdb-932a-f1031d10984f
Get alerted when CVE-2022-3231 or the next vulnerability affects your stack