What’s Vulnerable › Vulnerabilities
CVE-2022-3235: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-18 · updated 2026-06-17
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0490.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36, 37
- vim/vim: before 9.0.0490 — fixed in 9.0.0490
How to fix
Upgrade to a fixed version: vim/vim 9.0.0490. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/1c3dd8ddcba63c1af5112e567215b3cec2de11d0
- https://huntr.dev/bounties/96d5f7a0-a834-4571-b73b-0fe523b941af
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4QI7AETXBHPC7SGA77Q7O5IEGULWYET7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GTBVD4J2SKVSWK4VBN5JP5OEVK6GDS3N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LSSEWQLK55MCNT4Z2IIJEJYEI5HLCODI/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/1c3dd8ddcba63c1af5112e567215b3cec2de11d0
- https://huntr.dev/bounties/96d5f7a0-a834-4571-b73b-0fe523b941af
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4QI7AETXBHPC7SGA77Q7O5IEGULWYET7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GTBVD4J2SKVSWK4VBN5JP5OEVK6GDS3N/
Get alerted when CVE-2022-3235 or the next vulnerability affects your stack