What’s Vulnerable › Vulnerabilities
CVE-2022-3246: Blog2Social < 6.9.10 - Subscriber+ SQLi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-89
Description
The Blog2Social: Social Media Auto Post & Scheduler WordPress plugin before 6.9.10 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by any authenticated users, such as subscribers
Affected products
- pr-gateway Blog2Social: Social Media Auto Post & Scheduler: before 6.9.10 — fixed in 6.9.10
How to fix
Upgrade to a fixed version: pr-gateway Blog2Social: Social Media Auto Post & Scheduler 6.9.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ece049b2-9a21-463d-9e8b-b4ce61919f0c
- https://wpscan.com/vulnerability/ece049b2-9a21-463d-9e8b-b4ce61919f0c
Get alerted when CVE-2022-3246 or the next vulnerability affects your stack