What’s Vulnerable › Vulnerabilities
CVE-2022-3247: Blog2Social < 6.9.10 - Subscriber+ SSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-918
Description
The Blog2Social: Social Media Auto Post & Scheduler WordPress plugin before 6.9.10 does not have authorisation in an AJAX action, and does not ensure that the URL to make a request to is an external one. As a result, any authenticated users, such as subscriber could perform SSRF attacks
Affected products
- pr-gateway Blog2Social: Social Media Auto Post & Scheduler: before 6.9.10 — fixed in 6.9.10
How to fix
Upgrade to a fixed version: pr-gateway Blog2Social: Social Media Auto Post & Scheduler 6.9.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ee312f22-ca58-451d-a1cb-3f78a6e5ecaf
- https://wpscan.com/vulnerability/ee312f22-ca58-451d-a1cb-3f78a6e5ecaf
Get alerted when CVE-2022-3247 or the next vulnerability affects your stack