What’s Vulnerable › Vulnerabilities
CVE-2022-32471
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-15 · updated 2026-06-17
- Weakness: CWE-367
Description
An issue was discovered in IhisiSmm in Insyde InsydeH2O with kernel 5.0 through 5.5. The IhisiDxe driver uses the command buffer to pass input and output data. By modifying the command buffer contents with DMA after the input parameters have been checked but before they are used, the IHISI SMM code may be convinced to modify SMRAM or OS, leading to possible data corruption or escalation of privileges.
Affected products
- Insydeh2O: from 5.0 before 5.2.05.27.37; from 5.3 before 5.3.05.36.37; from 5.4 before 5.4.05.44.45; from 5.5 before 5.5.05.52.45 — fixed in 5.2.05.27.37, 5.3.05.36.37, 5.4.05.44.45, 5.5.05.52.45
How to fix
Upgrade to a fixed version: Insydeh2O 5.2.05.27.37, 5.3.05.36.37, 5.4.05.44.45, 5.5.05.52.45. Check the vendor advisory for mitigations.
References
- https://www.insyde.com/security-pledge
- https://www.insyde.com/security-pledge/SA-2023003
- https://www.insyde.com/security-pledge
- https://www.insyde.com/security-pledge/SA-2023003
Get alerted when CVE-2022-32471 or the next vulnerability affects your stack