What’s Vulnerable › Vulnerabilities
CVE-2022-3255: Cross-site Scripting (XSS) - Reflected in pimcore/pimcore
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-21 · updated 2026-06-17
- Weakness: CWE-79
Description
If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that user. Amongst other things, the attacker can: Perform any action within the application that the user can perform. View any information that the user is able to view. Modify any information that the user is able to modify. Initiate interactions with other application users, including malicious attacks, that will appear to originate from the initial victim user.
Affected products
- pimcore/pimcore: before 10.5.7 — fixed in 10.5.7
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/1e916e7d668c9e47b217e20cc0ea4812f466201b
- https://huntr.dev/bounties/0ea45cf9-b256-454c-9031-2435294c0902
- https://github.com/pimcore/pimcore/commit/1e916e7d668c9e47b217e20cc0ea4812f466201b
- https://huntr.dev/bounties/0ea45cf9-b256-454c-9031-2435294c0902
Get alerted when CVE-2022-3255 or the next vulnerability affects your stack