What’s Vulnerable › Vulnerabilities
CVE-2022-32553
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-23 · updated 2026-06-17
Description
Pure Storage FlashArray products running Purity//FA 6.2.0 - 6.2.3, 6.1.0 - 6.1.12, 6.0.0 - 6.0.8, 5.3.0 - 5.3.17, 5.2.x and prior Purity//FA releases, and Pure Storage FlashBlade products running Purity//FB 3.3.0, 3.2.0 - 3.2.4, 3.1.0 - 3.1.12, 3.0.x and prior Purity//FB releases are vulnerable to a privilege escalation via the manipulation of environment variables which can be exploited by a logged-in user to escape a restricted shell to an unrestricted shell with root privileges. No other Pure Storage products or services are affected. Remediation is available from Pure Storage via a self-serve “opt-in” patch, manual patch application or a software upgrade to an unaffected version of Purity software.
Affected products
- PureStorage Purity//Fa: before 5.3.18; from 6.0.0 before 6.0.9; from 6.1.0 before 6.1.13; from 6.2.0 before 6.2.4 — fixed in 5.3.18, 6.0.9, 6.1.13, 6.2.4
- PureStorage Purity//Fb: before 3.1.13; from 3.2.0 before 3.2.5; from 3.3.0 before 3.3.1 — fixed in 3.1.13, 3.2.5, 3.3.1
How to fix
Upgrade to a fixed version: PureStorage Purity//Fa 5.3.18, 6.0.9, 6.1.13, 6.2.4; PureStorage Purity//Fb 3.1.13, 3.2.5, 3.3.1. Check the vendor advisory for mitigations.
References
- https://support.purestorage.com/Pure_Security/Security_Bundle_2022-04-04/Security_Advisory_for_%E2%80%9Csecurity-bundle-2022-04-04
- https://support.purestorage.com/Pure_Security/Security_Bundle_2022-04-04/Security_Advisory_for_%E2%80%9Csecurity-bundle-2022-04-04
Get alerted when CVE-2022-32553 or the next vulnerability affects your stack