What’s Vulnerable › Vulnerabilities

CVE-2022-32554

Description

Pure Storage FlashArray products running Purity//FA 6.2.0 - 6.2.3, 6.1.0 - 6.1.12, 6.0.0 - 6.0.8, 5.3.0 - 5.3.17, 5.2.x and prior Purity//FA releases, and Pure Storage FlashBlade products running Purity//FB 3.3.0, 3.2.0 - 3.2.4, 3.1.0 - 3.1.12, 3.0.x and prior Purity//FB releases are vulnerable to possibly exposed credentials for accessing the product’s management interface. The password may be known outside Pure Storage and could be used on an affected system, if reachable, to execute arbitrary instructions with root privileges. No other Pure Storage products or services are affected. Remediation is available from Pure Storage via a self-serve “opt-in” patch, manual patch application or a software upgrade to an unaffected version of Purity software.

Affected products

How to fix

Upgrade to a fixed version: PureStorage Purity//Fa 5.3.18, 6.0.9, 6.1.13, 6.2.4; PureStorage Purity//Fb 3.1.13, 3.2.5, 3.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-32554 or the next vulnerability affects your stack