What’s Vulnerable › Vulnerabilities
CVE-2022-32587: WordPress WP Page Widget plugin <= 3.9 - Cross-Site Request Forgery (CSRF) vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-08 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in CodeAndMore WP Page Widget plugin <= 3.9 on WordPress leading to plugin settings change.
Affected products
- CodeAndMore WP Page Widget (WordPress plugin): before 4.0 — fixed in 4.0
How to fix
Upgrade to a fixed version: CodeAndMore WP Page Widget (WordPress plugin) 4.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-page-widget/wordpress-wp-page-widget-plugin-3-9-cross-site-request-forgery-csrf-vulnerability
- https://wordpress.org/plugins/wp-page-widget/
- https://patchstack.com/database/vulnerability/wp-page-widget/wordpress-wp-page-widget-plugin-3-9-cross-site-request-forgery-csrf-vulnerability
- https://wordpress.org/plugins/wp-page-widget/
Get alerted when CVE-2022-32587 or the next vulnerability affects your stack