What’s Vulnerable › Vulnerabilities

CVE-2022-3265

Description

A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2. It was possible to exploit a vulnerability in setting the labels colour feature which could lead to a stored XSS that allowed attackers to perform arbitrary actions on behalf of victims at client side.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.3.5, 15.4.4, 15.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3265 or the next vulnerability affects your stack