What’s Vulnerable › Vulnerabilities
CVE-2022-32742
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-25 · updated 2026-06-17
- Weakness: CWE-200
Description
A flaw was found in Samba. Some SMB1 write requests were not correctly range-checked to ensure the client had sent enough data to fulfill the write, allowing server memory contents to be written into the file (or printer) instead of client-supplied data. The client cannot control the area of the server memory written to the file (or printer).
Affected products
- Samba: before 4.14.14; from 4.15.0 before 4.15.9; from 4.16.0 before 4.16.4 — fixed in 4.14.14, 4.15.9, 4.16.4
How to fix
Upgrade to a fixed version: Samba 4.14.14, 4.15.9, 4.16.4. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2024/04/msg00015.html
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2022-32742.html
- https://lists.debian.org/debian-lts-announce/2024/04/msg00015.html
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2022-32742.html
Get alerted when CVE-2022-32742 or the next vulnerability affects your stack