What’s Vulnerable › Vulnerabilities
CVE-2022-32745
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-25 · updated 2026-06-17
- Weakness: CWE-125
Description
A flaw was found in Samba. Samba AD users can cause the server to access uninitialized data with an LDAP add or modify the request, usually resulting in a segmentation fault.
Affected products
- Samba: from 4.13.14 before 4.14.14; from 4.15.2 before 4.15.9; from 4.16.0 before 4.16.4 — fixed in 4.14.14, 4.15.9, 4.16.4
How to fix
Upgrade to a fixed version: Samba 4.14.14, 4.15.9, 4.16.4. Check the vendor advisory for mitigations.
References
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2022-32745.html
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2022-32745.html
Get alerted when CVE-2022-32745 or the next vulnerability affects your stack