What’s Vulnerable › Vulnerabilities
CVE-2022-32749: Apache Traffic Server: Improperly handled requests can cause crashes in specific plugins
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-19 · updated 2026-06-17
- Weakness: CWE-754
Description
Improper Check for Unusual or Exceptional Conditions vulnerability handling requests in Apache Traffic Server allows an attacker to crash the server under certain conditions. This issue affects Apache Traffic Server: from 8.0.0 through 9.1.3.
Affected products
- Apache Software Foundation Apache Traffic Server: from 8.0.0 before 8.1.6; from 9.0.0 before 9.1.4 — fixed in 8.1.6, 9.1.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Traffic Server 8.1.6, 9.1.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/mrj2lg4s0hf027rk7gz8t7hbn9xpfg02
- https://lists.apache.org/thread/mrj2lg4s0hf027rk7gz8t7hbn9xpfg02
Get alerted when CVE-2022-32749 or the next vulnerability affects your stack