What’s Vulnerable › Vulnerabilities
CVE-2022-3276: Puppetlabs-mysql Command Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-07 · updated 2026-06-17
- Weakness: CWE-78
Description
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
Affected products
- puppetlabs-mysql: before 13.0.0 — fixed in 13.0.0
How to fix
Upgrade to a fixed version: puppetlabs-mysql 13.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-3276 or the next vulnerability affects your stack