What’s Vulnerable › Vulnerabilities
CVE-2022-3283
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-17 · updated 2026-06-17
- Weakness: CWE-400
Description
A potential DOS vulnerability was discovered in GitLab CE/EE affecting all versions before before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1 While cloning an issue with special crafted content added to the description could have been used to trigger high CPU usage.
Affected products
- GitLab: before 15.2.5; from 15.3 before 15.3.4; from 15.4 before 15.4.1 — fixed in 15.2.5, 15.3.4, 15.4.1
How to fix
Upgrade to a fixed version: GitLab 15.2.5, 15.3.4, 15.4.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3283.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/361982
- https://hackerone.com/reports/1543718
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3283.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/361982
- https://hackerone.com/reports/1543718
Get alerted when CVE-2022-3283 or the next vulnerability affects your stack