What’s Vulnerable › Vulnerabilities
CVE-2022-32840
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-24 · updated 2026-06-17
- Weakness: CWE-269
Description
This issue was addressed with improved checks. This issue is fixed in macOS Monterey 12.5, watchOS 8.7, iOS 15.6 and iPadOS 15.6. An app may be able to execute arbitrary code with kernel privileges.
Affected products
- Apple iPadOS: before 15.6 — fixed in 15.6
- Apple Iphone Os: before 15.6 — fixed in 15.6
- Apple macOS: from 12.0 before 12.5 — fixed in 12.5
- Apple watchOS: before 8.7 — fixed in 8.7
How to fix
Upgrade to a fixed version: Apple iPadOS 15.6; Apple Iphone Os 15.6; Apple macOS 12.5; Apple watchOS 8.7. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/HT213340
- https://support.apple.com/en-us/HT213345
- https://support.apple.com/en-us/HT213346
- https://support.apple.com/en-us/HT213340
- https://support.apple.com/en-us/HT213345
- https://support.apple.com/en-us/HT213346
Get alerted when CVE-2022-32840 or the next vulnerability affects your stack