What’s Vulnerable › Vulnerabilities
CVE-2022-3285
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-09 · updated 2026-06-17
Description
Bypass of healthcheck endpoint allow list affecting all versions from 12.0 prior to 15.2.5, 15.3 prior to 15.3.4, and 15.4 prior to 15.4.1 allows an unauthorized attacker to prevent access to GitLab
Affected products
- GitLab: from 12.0.0 before 15.2.5; from 15.3.0 before 15.3.4; 15.4.0 — fixed in 15.2.5, 15.3.4
How to fix
Upgrade to a fixed version: GitLab 15.2.5, 15.3.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3285.json
- https://gitlab.com/gitlab-org/security/omnibus-gitlab/-/issues/64
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3285.json
- https://gitlab.com/gitlab-org/security/omnibus-gitlab/-/issues/64
Get alerted when CVE-2022-3285 or the next vulnerability affects your stack