What’s Vulnerable › Vulnerabilities
CVE-2022-32852
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-23 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read issue was addressed with improved input validation. This issue is fixed in macOS Monterey 12.5. Processing a maliciously crafted AppleScript binary may result in unexpected termination or disclosure of process memory.
Affected products
- Apple macOS: from 12.0 before 12.5 — fixed in 12.5
How to fix
Upgrade to a fixed version: Apple macOS 12.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-32852 or the next vulnerability affects your stack