What’s Vulnerable › Vulnerabilities
CVE-2022-32893: Apple iOS and macOS Out-of-Bounds Write Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-08-18
- EPSS: 9.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-24 · updated 2026-06-17
- Weakness: CWE-787
Description
An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 15.6.1 and iPadOS 15.6.1, macOS Monterey 12.5.1, Safari 15.6.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited.
Affected products
- Apple iPadOS: before 15.6.1 — fixed in 15.6.1
- Apple Iphone Os: before 15.6.1 — fixed in 15.6.1
- Apple macOS: from 12.0 before 12.5.1 — fixed in 12.5.1
- Apple Safari: before 15.6.1 — fixed in 15.6.1
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 35, 36
- Webkit: before 2.36.7 — fixed in 2.36.7
- Wpewebkit Wpe Webkit: before 2.36.7 — fixed in 2.36.7
How to fix
Upgrade to a fixed version: Apple iPadOS 15.6.1; Apple Iphone Os 15.6.1; Apple macOS 12.5.1; Apple Safari 15.6.1; Webkit 2.36.7; Wpewebkit Wpe Webkit 2.36.7. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Aug/16
- http://seclists.org/fulldisclosure/2022/Oct/49
- http://www.openwall.com/lists/oss-security/2022/08/25/5
- http://www.openwall.com/lists/oss-security/2022/08/26/2
- http://www.openwall.com/lists/oss-security/2022/08/29/1
- http://www.openwall.com/lists/oss-security/2022/08/29/2
- http://www.openwall.com/lists/oss-security/2022/09/02/10
- http://www.openwall.com/lists/oss-security/2022/09/13/1
- https://lists.debian.org/debian-lts-announce/2022/08/msg00019.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7SETAAXEPGNBMYKTUDFEZHS5LGSQ64QL/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YKJGV2EXVMYQW3OAJNI4WUTKKVMD2YYK/
- https://security.gentoo.org/glsa/202208-39
Get alerted when CVE-2022-32893 or the next vulnerability affects your stack