What’s Vulnerable › Vulnerabilities
CVE-2022-32908
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-20 · updated 2026-06-17
- Weakness: CWE-787
Description
A memory corruption issue was addressed with improved input validation. This issue is fixed in macOS Monterey 12.6, iOS 15.7 and iPadOS 15.7, iOS 16, macOS Big Sur 11.7. A user may be able to elevate privileges.
Affected products
- Apple iPadOS: before 15.7 — fixed in 15.7
- Apple Iphone Os: before 15.7 — fixed in 15.7
- Apple macOS: from 11.0 before 11.7; from 12.0.0 before 12.6 — fixed in 11.7, 12.6
- Apple tvOS: before 16.0 — fixed in 16.0
- Apple watchOS: before 9.0 — fixed in 9.0
How to fix
Upgrade to a fixed version: Apple iPadOS 15.7; Apple Iphone Os 15.7; Apple macOS 11.7, 12.6; Apple tvOS 16.0; Apple watchOS 9.0. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/39
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://support.apple.com/en-us/HT213443
- https://support.apple.com/en-us/HT213444
- https://support.apple.com/en-us/HT213445
- https://support.apple.com/en-us/HT213446
- https://support.apple.com/kb/HT213486
- https://support.apple.com/kb/HT213487
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/39
Get alerted when CVE-2022-32908 or the next vulnerability affects your stack