What’s Vulnerable › Vulnerabilities
CVE-2022-32915
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-01 · updated 2026-06-17
- Weakness: CWE-843
Description
A type confusion issue was addressed with improved checks. This issue is fixed in macOS Ventura 13. An app may be able to execute arbitrary code with kernel privileges.
Affected products
- Apple macOS: before 12.6.3 — fixed in 12.6.3
How to fix
Upgrade to a fixed version: Apple macOS 12.6.3. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Jan/20
- https://support.apple.com/en-us/HT213488
- https://support.apple.com/kb/HT213604
- http://seclists.org/fulldisclosure/2023/Jan/20
- https://support.apple.com/en-us/HT213488
- https://support.apple.com/kb/HT213604
Get alerted when CVE-2022-32915 or the next vulnerability affects your stack