What’s Vulnerable › Vulnerabilities
CVE-2022-32917: Apple iOS, iPadOS, and macOS Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-09-14
- EPSS: 5.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-20 · updated 2026-06-17
- Weakness: CWE-787
Description
The issue was addressed with improved bounds checks. This issue is fixed in macOS Monterey 12.6, iOS 15.7 and iPadOS 15.7, iOS 16, macOS Big Sur 11.7. An application may be able to execute arbitrary code with kernel privileges. Apple is aware of a report that this issue may have been actively exploited..
Affected products
- Apple iPadOS: before 15.7 — fixed in 15.7
- Apple Iphone Os: before 15.7 — fixed in 15.7
- Apple macOS: from 11.0 before 11.7; from 12.0.0 before 12.6 — fixed in 11.7, 12.6
How to fix
Upgrade to a fixed version: Apple iPadOS 15.7; Apple Iphone Os 15.7; Apple macOS 11.7, 12.6. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/39
- http://seclists.org/fulldisclosure/2022/Oct/40
- http://seclists.org/fulldisclosure/2022/Oct/43
- http://seclists.org/fulldisclosure/2022/Oct/45
- https://support.apple.com/en-us/HT213443
- https://support.apple.com/en-us/HT213444
- https://support.apple.com/en-us/HT213445
- https://support.apple.com/en-us/HT213446
- http://seclists.org/fulldisclosure/2022/Oct/39
- http://seclists.org/fulldisclosure/2022/Oct/40
- http://seclists.org/fulldisclosure/2022/Oct/43
- http://seclists.org/fulldisclosure/2022/Oct/45
Get alerted when CVE-2022-32917 or the next vulnerability affects your stack