What’s Vulnerable › Vulnerabilities
CVE-2022-32941
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-01 · updated 2026-06-17
- Weakness: CWE-120
Description
The issue was addressed with improved bounds checks. This issue is fixed in iOS 15.7.1 and iPadOS 15.7.1, macOS Ventura 13, iOS 16.1 and iPadOS 16, macOS Monterey 12.6.1, macOS Big Sur 11.7.1. A buffer overflow may result in arbitrary code execution.
Affected products
- Apple iPadOS: before 15.7.1 — fixed in 15.7.1
- Apple Iphone Os: before 15.7.1; 16.0 — fixed in 15.7.1
- Apple macOS: from 11.0 before 11.7.1; from 12.0.0 before 12.6.1 — fixed in 11.7.1, 12.6.1
How to fix
Upgrade to a fixed version: Apple iPadOS 15.7.1; Apple Iphone Os 15.7.1; Apple macOS 11.7.1, 12.6.1. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/HT213488
- https://support.apple.com/en-us/HT213489
- https://support.apple.com/en-us/HT213490
- https://support.apple.com/en-us/HT213493
- https://support.apple.com/en-us/HT213494
- https://support.apple.com/en-us/HT213488
- https://support.apple.com/en-us/HT213489
- https://support.apple.com/en-us/HT213490
- https://support.apple.com/en-us/HT213493
- https://support.apple.com/en-us/HT213494
Get alerted when CVE-2022-32941 or the next vulnerability affects your stack