What’s Vulnerable › Vulnerabilities
CVE-2022-3296: Stack-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-25 · updated 2026-09-24
- Weakness: CWE-121
Description
Stack-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0577.
Affected products
- Fedoraproject Fedora: 35, 36, 37
- Neovim: from 0.1.0 before 0.9.0 — fixed in 0.9.0
- vim/vim: before 9.0.0577 — fixed in 9.0.0577
How to fix
Upgrade to a fixed version: Neovim 0.9.0; vim/vim 9.0.0577. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/96b9bf8f74af8abf1e30054f996708db7dc285be
- https://huntr.dev/bounties/958866b8-526a-4979-9471-39392e0c9077
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4QI7AETXBHPC7SGA77Q7O5IEGULWYET7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GTBVD4J2SKVSWK4VBN5JP5OEVK6GDS3N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LSSEWQLK55MCNT4Z2IIJEJYEI5HLCODI/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/96b9bf8f74af8abf1e30054f996708db7dc285be
- https://huntr.dev/bounties/958866b8-526a-4979-9471-39392e0c9077
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4QI7AETXBHPC7SGA77Q7O5IEGULWYET7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GTBVD4J2SKVSWK4VBN5JP5OEVK6GDS3N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LSSEWQLK55MCNT4Z2IIJEJYEI5HLCODI/
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-3296 or the next vulnerability affects your stack