What’s Vulnerable › Vulnerabilities
CVE-2022-32969
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-29 · updated 2026-06-17
- Weakness: CWE-281
Description
MetaMask before 10.11.3 might allow an attacker to access a user's secret recovery phrase because an input field is used for a BIP39 mnemonic, and Firefox and Chromium save such fields to disk in order to support the Restore Session feature, aka the Demonic issue.
Affected products
- Metamask: before 10.11.3 — fixed in 10.11.3
How to fix
Upgrade to a fixed version: Metamask 10.11.3. Check the vendor advisory for mitigations.
References
- https://github.com/MetaMask/metamask-extension/compare/v10.11.2...v10.11.3
- https://halborn.com/disclosures/demonic-vulnerability/
- https://halborn.com/halborn-discovers-critical-vulnerability-affecting-crypto-wallet-browser-extensions/
- https://github.com/MetaMask/metamask-extension/compare/v10.11.2...v10.11.3
- https://halborn.com/disclosures/demonic-vulnerability/
- https://halborn.com/halborn-discovers-critical-vulnerability-affecting-crypto-wallet-browser-extensions/
Get alerted when CVE-2022-32969 or the next vulnerability affects your stack