What’s Vulnerable › Vulnerabilities
CVE-2022-3297: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-25 · updated 2026-09-24
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0579.
Affected products
- Fedoraproject Fedora: 35, 36, 37
- Neovim: from 0.5.0 before 0.10.0 — fixed in 0.10.0
- vim/vim: before 9.0.0579 — fixed in 9.0.0579
How to fix
Upgrade to a fixed version: Neovim 0.10.0; vim/vim 9.0.0579. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/0ff01835a40f549c5c4a550502f62a2ac9ac447c
- https://huntr.dev/bounties/1aa9ec92-0355-4710-bf85-5bce9effa01c
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4QI7AETXBHPC7SGA77Q7O5IEGULWYET7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GTBVD4J2SKVSWK4VBN5JP5OEVK6GDS3N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LSSEWQLK55MCNT4Z2IIJEJYEI5HLCODI/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/0ff01835a40f549c5c4a550502f62a2ac9ac447c
- https://huntr.dev/bounties/1aa9ec92-0355-4710-bf85-5bce9effa01c
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4QI7AETXBHPC7SGA77Q7O5IEGULWYET7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GTBVD4J2SKVSWK4VBN5JP5OEVK6GDS3N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LSSEWQLK55MCNT4Z2IIJEJYEI5HLCODI/
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-3297 or the next vulnerability affects your stack