What’s Vulnerable › Vulnerabilities

CVE-2022-32981

Description

An issue was discovered in the Linux kernel through 5.18.3 on powerpc 32-bit platforms. There is a buffer overflow in ptrace PEEKUSER and POKEUSER (aka PEEKUSR and POKEUSR) when accessing floating point registers.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.14.283, 4.19.247, 4.9.318, 5.10.122. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-32981 or the next vulnerability affects your stack