What’s Vulnerable › Vulnerabilities
CVE-2022-32997
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-24 · updated 2026-06-17
Description
The RootInteractive package in PyPI v0.0.5 to v0.0.19b0 was discovered to contain a code execution backdoor via the request package. This vulnerability allows attackers to access sensitive user information and digital currency keys, as well as escalate privileges.
Affected products
- Pypi Rootinteractive: from 0.0.5 before 0.0.19; 0.0.19, 0.0.19-b0 — fixed in 0.0.19
How to fix
Upgrade to a fixed version: Pypi Rootinteractive 0.0.19. Check the vendor advisory for mitigations.
References
- http://pypi.doubanio.com/simple/request
- https://github.com/miranov25/RootInteractive/issues/206
- https://pypi.org/project/RootInteractive/
- http://pypi.doubanio.com/simple/request
- https://github.com/miranov25/RootInteractive/issues/206
- https://pypi.org/project/RootInteractive/
Get alerted when CVE-2022-32997 or the next vulnerability affects your stack