What’s Vulnerable › Vulnerabilities
CVE-2022-33182
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-276
Description
A privilege escalation vulnerability in Brocade Fabric OS CLI before Brocade Fabric OS v9.1.0, 9.0.1e, 8.2.3c, 8.2.0cbn5, could allow a local authenticated user to escalate its privilege to root using switch commands “supportlink”, “firmwaredownload”, “portcfgupload, license, and “fosexec”.
Affected products
- Brocade Fabric OS: from 8.0.0 before 8.2.3c; from 9.0.0 before 9.0.1e — fixed in 8.2.3c, 9.0.1e
How to fix
Upgrade to a fixed version: Brocade Fabric OS 8.2.3c, 9.0.1e. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20230127-0007/
- https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2022-2084
- https://security.netapp.com/advisory/ntap-20230127-0007/
- https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2022-2084
Get alerted when CVE-2022-33182 or the next vulnerability affects your stack