What’s Vulnerable › Vulnerabilities
CVE-2022-33185
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-787
Description
Several commands in Brocade Fabric OS before Brocade Fabric OS v.9.0.1e, and v9.1.0 use unsafe string functions to process user input. Authenticated local attackers could abuse these vulnerabilities to exploit stack-based buffer overflows, allowing arbitrary code execution as the root user account.
Affected products
- Brocade Fabric OS: before 9.0.1e — fixed in 9.0.1e
How to fix
Upgrade to a fixed version: Brocade Fabric OS 9.0.1e. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20230127-0010/
- https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2022-2078
- https://security.netapp.com/advisory/ntap-20230127-0010/
- https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2022-2078
Get alerted when CVE-2022-33185 or the next vulnerability affects your stack