What’s Vulnerable › Vulnerabilities
CVE-2022-3324: Stack-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-27 · updated 2026-09-24
- Weakness: CWE-121
Description
Stack-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0598.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 35, 36, 37
- Neovim: from 0.1.0 before 0.9.5 — fixed in 0.9.5
- vim/vim: before 9.0.0598 — fixed in 9.0.0598
How to fix
Upgrade to a fixed version: Neovim 0.9.5; vim/vim 9.0.0598. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/8279af514ca7e5fd3c31cf13b0864163d1a0bfeb
- https://huntr.dev/bounties/e414e55b-f332-491f-863b-c18dca97403c
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4QI7AETXBHPC7SGA77Q7O5IEGULWYET7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GTBVD4J2SKVSWK4VBN5JP5OEVK6GDS3N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LSSEWQLK55MCNT4Z2IIJEJYEI5HLCODI/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/8279af514ca7e5fd3c31cf13b0864163d1a0bfeb
- https://huntr.dev/bounties/e414e55b-f332-491f-863b-c18dca97403c
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4QI7AETXBHPC7SGA77Q7O5IEGULWYET7/
Get alerted when CVE-2022-3324 or the next vulnerability affects your stack