What’s Vulnerable › Vulnerabilities

CVE-2022-3325

Description

Improper access control in the GitLab CE/EE API affecting all versions starting from 12.8 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1. Allowed for editing the approval rules via the API by an unauthorised user.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.2.5, 15.3.4, 15.4.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3325 or the next vulnerability affects your stack