What’s Vulnerable › Vulnerabilities
CVE-2022-3326: Weak Password Requirements in ikus060/rdiffweb
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-29 · updated 2026-06-17
- Weakness: CWE-521
Description
Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.9.
Affected products
- ikus060/rdiffweb: before 2.4.9 — fixed in 2.4.9
How to fix
Upgrade to a fixed version: ikus060/rdiffweb 2.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/ikus060/rdiffweb/commit/ee98e5af78ec60db8a17fef6ea0ca250e3f31eec
- https://huntr.dev/bounties/1f6a5e49-23f2-45f7-8661-19f9cee8ae97
- https://github.com/ikus060/rdiffweb/commit/ee98e5af78ec60db8a17fef6ea0ca250e3f31eec
- https://huntr.dev/bounties/1f6a5e49-23f2-45f7-8661-19f9cee8ae97
Get alerted when CVE-2022-3326 or the next vulnerability affects your stack