What’s Vulnerable › Vulnerabilities
CVE-2022-3328
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-08 · updated 2026-06-17
- Weakness: CWE-362
Description
Race condition in snap-confine's must_mkdir_and_open_with_perms()
Affected products
- Canonical Ltd. snapd: before 2.61.1 — fixed in 2.61.1
- Canonical Ubuntu Linux: 16.04, 18.04, 20.04, 22.04, 22.10
How to fix
Upgrade to a fixed version: Canonical Ltd. snapd 2.61.1. Check the vendor advisory for mitigations.
References
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-3328
- https://ubuntu.com/security/notices/USN-5753-1
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-3328
- https://ubuntu.com/security/notices/USN-5753-1
Get alerted when CVE-2022-3328 or the next vulnerability affects your stack