What’s Vulnerable › Vulnerabilities
CVE-2022-3335: Kadence WooCommerce Email Designer < 1.5.7 - Admin+ PHP Objection Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-502
Description
The Kadence WooCommerce Email Designer WordPress plugin before 1.5.7 unserialises the content of an imported file, which could lead to PHP object injections issues when an admin import (intentionally or not) a malicious file and a suitable gadget chain is present on the blog.
Affected products
- Kadence WooCommerce Email Designer: before 1.5.7 — fixed in 1.5.7
How to fix
Upgrade to a fixed version: Kadence WooCommerce Email Designer 1.5.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/39514705-c887-4a02-a77b-36e1dcca8f5d
- https://wpscan.com/vulnerability/39514705-c887-4a02-a77b-36e1dcca8f5d
Get alerted when CVE-2022-3335 or the next vulnerability affects your stack