What’s Vulnerable › Vulnerabilities
CVE-2022-3355: Cross-site Scripting (XSS) - Stored in inventree/inventree
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository inventree/inventree prior to 0.8.3.
Affected products
- InvenTree: before 0.8.3 — fixed in 0.8.3
How to fix
Upgrade to a fixed version: InvenTree 0.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/inventree/inventree/commit/5a08ef908dd5344b4433436a4679d122f7f99e41
- https://huntr.dev/bounties/4b7fb92c-f06b-4bbf-82dc-9f013b30b6a6
- https://github.com/inventree/inventree/commit/5a08ef908dd5344b4433436a4679d122f7f99e41
- https://huntr.dev/bounties/4b7fb92c-f06b-4bbf-82dc-9f013b30b6a6
Get alerted when CVE-2022-3355 or the next vulnerability affects your stack