What’s Vulnerable › Vulnerabilities
CVE-2022-3360: LearnPress < 4.1.7.2 - Unauthenticated PHP Object Injection via REST API
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-31 · updated 2026-06-17
- Weakness: CWE-502
Description
The LearnPress WordPress plugin before 4.1.7.2 unserialises user input in a REST API endpoint available to unauthenticated users, which could lead to PHP Object Injection when a suitable gadget is present, leadint to remote code execution (RCE). To successfully exploit this vulnerability attackers must have knowledge of the site secrets, allowing them to generate a valid hash via the wp_hash() function.
Affected products
- thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses: before 4.1.7.2 — fixed in 4.1.7.2
How to fix
Upgrade to a fixed version: thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses 4.1.7.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/acea7a54-a964-4127-a93f-f38f883074e3
- https://wpscan.com/vulnerability/acea7a54-a964-4127-a93f-f38f883074e3
Get alerted when CVE-2022-3360 or the next vulnerability affects your stack