What’s Vulnerable › Vulnerabilities
CVE-2022-3362: Insufficient Session Expiration in ikus060/rdiffweb
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-14 · updated 2026-06-17
- Weakness: CWE-613
Description
Insufficient Session Expiration in GitHub repository ikus060/rdiffweb prior to 2.5.0.
Affected products
- ikus060/rdiffweb: before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: ikus060/rdiffweb 2.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/ikus060/rdiffweb/commit/6efb995bc32c8a8e9ad755eb813dec991dffb2b8
- https://huntr.dev/bounties/ca428c31-858d-47fa-adc9-2a59f8e8b2b1
- https://github.com/ikus060/rdiffweb/commit/6efb995bc32c8a8e9ad755eb813dec991dffb2b8
- https://huntr.dev/bounties/ca428c31-858d-47fa-adc9-2a59f8e8b2b1
Get alerted when CVE-2022-3362 or the next vulnerability affects your stack