What’s Vulnerable › Vulnerabilities
CVE-2022-33681: Improper Hostname Verification in Java Client and Proxy can expose authentication data via MITM
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-23 · updated 2026-06-17
- Weakness: CWE-295
Description
Delayed TLS hostname verification in the Pulsar Java Client and the Pulsar Proxy make each client vulnerable to a man in the middle attack. Connections from the Pulsar Java Client to the Pulsar Broker/Proxy and connections from the Pulsar Proxy to the Pulsar Broker are vulnerable. Authentication data is sent before verifying the server’s TLS certificate matches the hostname, which means authentication data could be exposed to an attacker. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack by providing the client with a cryptographically valid certificate for an unrelated host. Because the client sends authentication data before performing hostname verification, an attacker could gain access to the client’s authentication data. The client eventually closes the connection when it verifies the hostname and identifies the targeted hostname does not match a hostname on the certificate. Because the client eventually closes the connection, the value of the intercepted authentication data depends on the authentication method used by the client. Token based authentication and username/password authentication methods are vulnerable because the authentication data can be used to impersonate the client in a separate session. This issue affects Apache Pulsar Java Client versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.
Affected products
- Apache Software Foundation Apache Pulsar: before 2.7.5; from 2.8.0 before 2.8.4; from 2.9.0 before 2.9.3; 2.10.0 — fixed in 2.7.5, 2.8.4, 2.9.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pulsar 2.7.5, 2.8.4, 2.9.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/fpo6x10trvn20hlk0dmnr5vlz5v4kl3d
- https://lists.apache.org/thread/fpo6x10trvn20hlk0dmnr5vlz5v4kl3d
Get alerted when CVE-2022-33681 or the next vulnerability affects your stack