What’s Vulnerable › Vulnerabilities
CVE-2022-33683: Disabled Certificate Validation makes Broker, Proxy Admin Clients vulnerable to MITM attack
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-23 · updated 2026-06-17
- Weakness: CWE-295
Description
Apache Pulsar Brokers and Proxies create an internal Pulsar Admin Client that does not verify peer TLS certificates, even when tlsAllowInsecureConnection is disabled via configuration. The Pulsar Admin Client's intra-cluster and geo-replication HTTPS connections are vulnerable to man in the middle attacks, which could leak authentication data, configuration data, and any other data sent by these clients. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. This issue affects Apache Pulsar Broker and Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.
Affected products
- Apache Software Foundation Apache Pulsar: before 2.7.5; from 2.8.0 before 2.8.4; from 2.9.0 before 2.9.3; 2.10.0 — fixed in 2.7.5, 2.8.4, 2.9.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pulsar 2.7.5, 2.8.4, 2.9.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/42v5rsxj36r3nhfxhmhb2x12r5jmvx3x
- https://lists.apache.org/thread/42v5rsxj36r3nhfxhmhb2x12r5jmvx3x
Get alerted when CVE-2022-33683 or the next vulnerability affects your stack