What’s Vulnerable › Vulnerabilities
CVE-2022-3379
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-27 · updated 2026-06-17
- Weakness: CWE-787
Description
Horner Automation's Cscape version 9.90 SP7 and prior does not properly validate user-supplied data. If a user opens a maliciously formed FNT file, then an attacker could execute arbitrary code within the current process by writing outside the memory buffer.
Affected products
- Horner Automation Cscape: before 9.90; 9.90, 9.90-sp1, 9.90-sp2, 9.90-sp3, 9.90-sp4, 9.90-sp5 (+2) — fixed in 9.90
How to fix
Upgrade to a fixed version: Horner Automation Cscape 9.90. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-277-03
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-277-03
Get alerted when CVE-2022-3379 or the next vulnerability affects your stack