What’s Vulnerable › Vulnerabilities
CVE-2022-33871
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-121
Description
A stack-based buffer overflow vulnerability [CWE-121] in FortiWeb version 7.0.1 and earlier, 6.4 all versions, version 6.3.19 and earlier may allow a privileged attacker to execute arbitrary code or commands via specifically crafted CLI `execute backup-local rename` and `execute backup-local show` operations.
Affected products
- Fortinet FortiWeb: from 6.3.6 before 6.3.20; 6.4.0, 6.4.1, 6.4.2, 7.0.0, 7.0.1 — fixed in 6.3.20
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 6.3.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-33871 or the next vulnerability affects your stack