What’s Vulnerable › Vulnerabilities
CVE-2022-33919
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-12 · updated 2026-06-17
- Weakness: CWE-200
Description
Dell GeoDrive, versions 2.1 - 2.2, contains an information disclosure vulnerability in GUI. An authenticated non-admin user could potentially exploit this vulnerability and view sensitive information.
Affected products
- Dell GeoDrive: from 2.1.0 before 2.2.3 — fixed in 2.2.3
How to fix
Upgrade to a fixed version: Dell GeoDrive 2.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-33919 or the next vulnerability affects your stack