What’s Vulnerable › Vulnerabilities
CVE-2022-33937
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-12 · updated 2026-06-17
- Weakness: CWE-23
Description
Dell GeoDrive, Versions 1.0 - 2.2, contain a Path Traversal Vulnerability in the reporting function. A local, low privileged attacker could potentially exploit this vulnerability, to gain unauthorized delete access to the files stored on the server filesystem, with the privileges of the GeoDrive service: NT AUTHORITY\SYSTEM.
Affected products
- Dell GeoDrive: before 2.2.3 — fixed in 2.2.3
How to fix
Upgrade to a fixed version: Dell GeoDrive 2.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-33937 or the next vulnerability affects your stack