What’s Vulnerable › Vulnerabilities
CVE-2022-3394: WP All Export Pro < 1.7.9 - Authenticated Code Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-94
Description
The WP All Export Pro WordPress plugin before 1.7.9 does not limit some functionality during exports only to users with the Administrator role, allowing any logged in user which has been given privileges to perform exports to execute arbitrary code on the site. By default only administrators can run exports, but the privilege can be delegated to lower privileged users.
Affected products
- WP All Export Pro: before 1.7.9 — fixed in 1.7.9
How to fix
Upgrade to a fixed version: WP All Export Pro 1.7.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3266eb59-a8b2-4a5a-ab48-01a9af631b2c
- https://wpscan.com/vulnerability/3266eb59-a8b2-4a5a-ab48-01a9af631b2c
Get alerted when CVE-2022-3394 or the next vulnerability affects your stack